Users unable to launch the published desktops and applications - XML errors on StoreFront servers

Users unable to launch the published desktops and applications - XML errors on StoreFront servers

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Article ID: CTX233424

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Updated On:

Description

  • Event ID 0, Task Category 12346:
    • No available resource found for user xxx@yyy.zzz when accessing desktop group "Remote Desktop - ABCXYZ". This message was reported from the Citrix XML Service at address http://xxx.yyy.zzz/scripts/wpnbr.dll [NFuseProtocol.TRequestAddress]. 
  • Event ID 28, Task Category 2001:
    • Failed to launch the resource 'Cloud Connectors.Remote Desktop - ABCXYZ' using the Citrix XML Service at address 'http://xxx.yyy.zzz/scripts/wpnbr.dll'. The XML service returned error: 'no-available-workstation'.
  • Event ID 0, Task Category 12346:
    • The Citrix servers sent HTTP headers indicating that an error occurred: 500 Internal Server Error. This message was reported from the XML Service at address http://xxx.yyy.zzz//scripts/ctxmcp.dll [MachineControlProtocol.TRequestPowerOffMachine]. The specified Citrix XML Service could not be contacted and has been temporarily removed from the list of active services.
  • Event ID 4003, Task Category 12346:
    • The Citrix servers reported an unspecified error from the XML Service at address http://xxx.yyy.zzz/scripts/wpnbr.dll [NFuseProtocol.TRequestAddress].
  • Event ID 4003, Task Category 12346:
    • All the Citrix XML Services configured for farm Cloud Connectors failed to respond to this XML Service transaction.
  • Event ID 28, Task Category 2001:
    • Failed to launch the resource 'Cloud Connectors.Remote Desktop' using the Citrix XML Service at address 'http://xxx.yyy.zzz//scripts/wpnbr.dll'. The XML service returned error: 'unspecified'.

Resolution

  1. Select the store on the StoreFront server
  2. Manage delivery controllers
  3. Edit Delivery controller
  4. Select Settings under the Advanced settings
  5. In the configure advanced settings page click in the second column and enter a time, in minutes, for which a single server is considered offline after it fails to respond.
    -This is a subjective value and should be configured based on the specific requirements. The default bypass duration is 60 minutes. You can try lowering the time depending on the issue. 
  • Bypass duration specifies the time in minutes that StoreFront bypasses an individual server after a failed attempt to contact that server. 

User-added image

 

Problem Cause

Issue was identified as the StoreFront server marking the cloud connectors as offline when there was a network interruption. Changing the value of  bypass duration time resolved the issue.

Issue/Introduction

Users unable to launch the published desktops and applications - Multiple XML errors on StoreFront servers

Additional Information

You can now use the Application probing feature to proactively monitor the health of applications enabling you to fix issues before the user actually experiences them. For more information refer to Citrix Documentation - Application probing.