XenDesktop Setup Wizard fails with error "The xsPvsSiteUuid Field Does not exist"

XenDesktop Setup Wizard fails with error "The xsPvsSiteUuid Field Does not exist"

book

Article ID: CTX233289

calendar_today

Updated On:

Description

When running the XenDesktop Setup Wizard (XDSW) you encounter the following error.

"The xsPvsSiteUuid Field Does not exist"

At this point the XDSW fails and aborts the process.

Resolution

Confirm that the version of the PVS Console matches the version of the PVS Server Software and all its components, including the Database Schema.

Use the following steps to confirm the versions installed for each PVS Server component:
  1. Open the PVS Console and connect to the Farm
    Note: It's recommended to connect to localhost to ensure we look at the components installed on the local server
  2. Right click on the Farm name and select "Version..." from the context menu. The Versions window will appear
  3. In the Versions window confirm that all components are running the same version
Below is an example of the Versions window for a PVS Server 7.16
Versions Window

To confirm the correct Database Schema version is used, refer to the following Citrix article: https://support.citrix.com/article/CTX233282

Problem Cause

This issue might be seen when there are disparate versions of the PVS components installed on the PVS Server.

The issue is even more likely to happen if the Database Schema version is not consistent with the version of the PVS Console and the other components.