Reboot Schedule Doesn't work for two Delivery Groups in XenApp

Reboot Schedule Doesn't work for two Delivery Groups in XenApp

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Article ID: CTX233189

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Updated On:

Description

Use Case: "We have a schedule to restart the machines in the delivery group every Sunday. The problem is that a few machines don't turn back on, others don't even receive the command to turn off."

Checking the Event Viewer logs in the Delivery Controller we see these errors:

Event ID 3105

Log name: Application

Source: Citrix Broker Service

Text: The Citrix Broker Service has terminated the processing of the GroupReboot for Desktop '[Delivery Group name]'  The reboot cycle UID = 999 ended with the final state 'Abandoned' Summary: '0' machines successfully rebooted, '2' machines failed to reboot. '1' machines were not processed

Environment

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Resolution

Run PowerShell command to remove reboot schedule entries in the Database and then Manually re-created the Reboot schedule via Studio-Delivery Group UI.


1. Issue PoSh command: Get-BrokerRebootSchedule At least 5 Reboot schedules for the Desktops were enumerated
2. Compare the Reboot schedule DB fields for all 5 DG's ; They should look identical
3. Issue command: Get-BrokerRebootSchedule -DesktopGRoupName "[Delivery Group name]" (got same results but only for the delivery group specified)

Recommended PoSh commands:
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Remove-BrokerRebootSchedule -DesktopGroupName "[Delivery Group name 1]"
Remove-BrokerRebootSchedule -DesktopGroupName "[Delivery Group name 2]"
Recreate reboot schedule for the two Delivery Groups via Studio UI (user interface)

Problem Cause

The Reboot schedule entries in the SQL database were either corrupted or had some minor inconsistencies for the two Delivery Groups affected

Issue/Introduction

Reboot schedule was created for 5 Delivery Groups. However for two of the Delivery groups the reboot did not occur

Additional Information

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/downloads/broker_events.htm