Applications Do Not Open in Seamless Mode After Upgrade to XenApp 7.15 CU1
book
Article ID: CTX233121
calendar_today
Updated On:
Description
After the uninstall of Server Virtual Delivery Agent 7.14, and install of Server Virtual Delivery Agent 7.5.1000, applications fail to load in seamless mode, and sessions remain open on the server even after exiting the application.
An investigation with Process Explorer shows that twi3.dll has not been loaded into Winlogon.exe for this session.
Environment
Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.
Resolution
Customer moved the C:\Program Files (x86)\Citrix\System32 directory to the first place in PATH, and seamless is now loaded properly. Sessions also close gracefully.
Problem Cause
The DLL responsible for starting the load of seamless functionality (ctxnotif.dll) was not loading correctly because a dependent DLL couldn't be find in the Windows PATH variable. C:\Program Files (x86)\Citrix\System32 was included in PATH, but a third party application's directory was taking priority.
Was this article helpful?
thumb_up
Yes
thumb_down
No