XenDesktop ICA Session Launch taking too long while validating user credentials

XenDesktop ICA Session Launch taking too long while validating user credentials

book

Article ID: CTX232617

calendar_today

Updated On:

Description

While it takes more time to launch the Citrix Session or to reconnect to an existing session, you may observe wait time on Credential Tiles and then eventually Welcome Screen will show up

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Check for any 3rd Party Credential Provider. As part of a Case Study, we could see the presence of Citrix Single Sign-On however the SSON Service was stopped and disabled, due to which it was taking more time to check for SSON and pass since the Service was disabled. Uninstalling SSON or enabling and starting SSON Service reduced the Launch time back to normal and we were able to resolve the issue. 

You could check for 3rd Party Credential Providers under Registry Location: HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\Credential Providers

Problem Cause

Presence of 3rd Party Credential Providers delays Desktop Launch

Issue/Introduction

We have seen issues where it takes more time than expected while launching a new ICA Session or reconnecting to an existing Session where excessive time is taken while validating the user credentials and getting the Credential tiles shown during the wait time