Application Crashes in Desktop Session When Using a Touchscreen Client

Application Crashes in Desktop Session When Using a Touchscreen Client

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Article ID: CTX232495

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Updated On:

Description

If an ICA Session is started from a Windows 10 client with touchscreen display (or iPhone/iPad, Surface) a  Powerbuilder application crashes.

If the Multi-touch screen is disabled in the client device manager the Powerbuilder application runs without errors.

Other applications which use Microsoft UI Automation can also be affected.

 

Resolution

To prevent the PowerBuilder application crashing and still allow the touchscreen in the session do the following.

1. Disable the "Citrix mobile receiver virtual channel service" on the VDA:

Pic1.jpg 

2. Disable these 3 Citrix mobility policies:

 pic2.jpg 


Problem Cause

If the Multi-touch service is disabled on the VDA then touch commands wont be redirect from the client. But even so, the MRVC (mobile receiver virtual channel ) service may be causing an application to trap if the combo box remoting policy is enabled. All the Microsoft UIAutomation related components get loaded into the app if the session is connected from a touch client with Autokeyboard popup/Remoting combo box features.

Please disable these policies and MRVC service if the app is having issues.

Issue/Introduction

If an ICA Session is started from a Windows 10 Surface client with touchscreen display (or iPhone/iPad, Surface) a Powerbuilder application crashes.