Error: The Citrix Desktop Service was refused a connection to the delivery controller "<xdcontroller FQDN> (IP Address 'xxx.xxx.xxx.xxx')

Error: The Citrix Desktop Service was refused a connection to the delivery controller "<xdcontroller FQDN> (IP Address 'xxx.xxx.xxx.xxx')

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Article ID: CTX232143

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Description

VDAs in Delivery Group losing registration with the Delivery Controllers. You may see Event ID 1023 logged:
The Citrix Desktop Service was refused a connection to the delivery controller "xdcontroller FQDN" (IP Address 'xxx.xxx.xxx.xxx').

In CDF trace you may see this error:
ConfigurationManagerService.Set Exception:Citrix.Cds.BrokerAgent.MxPolicyManagerException: ProcessMultipleMxPolicies: Error while saving policy settings - Location=C:\Program Files\Citrix\PvsVm\Service\PersistedData\BrokerAgentInfo Exception=System.IO.IOException: There is not enough space on the disk.

Resolution

Try to determine which files are taking up disk space on Identity disk.

For access to the junction linked to the Identity Disk volume at C:\Program Files\Citrix\PvsVm\Service\PersistedData\, you will need to execute the command prompt under the context of the Local System account via PsExec tool.

The PsExec tool is available for download at this location - http://docs.microsoft.com/en-us/sysinternals/downloads/psexec

Follow these steps to access the Identity disk volume on the VDA:

1. Open elevated command prompt <Run as administrator>

2. Execute the command under the context of the Local System account via PsExec:
PSEXEC -i -s cmd.exe 

This is to access the junction linked to the Identity Disk volume.

3. Navigate to the root of the junction "\PersistedData", and execute the following command:
DIR /O:S /S > C:\{location}\Out.txt

4. Open out.txt using Notepad or text editor

5. Check the files taking up the disk space.

6. Move the unwanted files to an alternate location or delete them

Note: You may see .gpf files which shouldn't be deleted. BrokerAgent.exe writes changed farm policies to %ProgramData%\Citrix\PvsAgent\LocallyPersistedData\BrokerAgentInfo\<GUID>.gpf. BrokerAgent.exe then triggers a policy evaluation via CitrixCseClient.dll. 
 

Problem Cause

The disk space on Identity disk is filled up with third party application files e.g. Backup log, application log file or antivirus logs etc.

Issue/Introduction

VDAs in Delivery Group losing registration with the Delivery Controllers.