Broken database connection for a Citrix XenApp/XenDesktop Controller Service

Broken database connection for a Citrix XenApp/XenDesktop Controller Service

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Article ID: CTX231029

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Updated On:

Description

Health Check has detected a broken database connection for one of the following  XenApp/XenDesktop Controller Services:

ADIdentity Service
Analytics Service
AppLibrary Service
Broker Service
Configuration Service
Delegated Admin Service
Environment Test Service
Host Availability Service
Machine Creation Service
Monitor Service
StoreFront Service
Trust Service
Orchestration Service

For more information about these services, refer to CTX139415- XenDesktop 7.x Services Overview

Resolution

Perform the following tasks to repair the broken database connection: 
  1. Verify that the database server is running, and reachable on the network.
  2. Check the hostname of the database server in the string and the database name on the database server.
  3. Look for any corruption or issues with the database. Refer to CTX127998 - Database Access and Permission Model for XenDesktop
  4. On the Delivery Controller, open a PowerShell command window.
  5. Type `asnp  Citrix*
  6. Ensure that the connection string is configured correctly, and that the database server is healthy and up and running by <INSERT>
    • Get-[Service]DBConnection -DataStore Site (for services with secondary database) Monitor, Log. 
    • Get-[Service]DBConnection
  7. If incorrect, null the connection, set the connection
  8. Ensure that the Delivery Controller can communicate with the database server. by <INSERT>
  9. Ping, 
  10. Restart the service Citrix Monitor service by <INSERT>
  11. Ensure the permissions on the database is configured correctly. Refer to CTX127998 - Database Access and Permission Model for XenDesktop

Problem Cause

A database connection string has been specified for the Controller Service, but the database is not compatible or working properly.