StoreFront - Unable to import configuration

StoreFront - Unable to import configuration

book

Article ID: CTX230362

calendar_today

Updated On:

Description

Unable to import StoreFront configuration from existing environment into a newly installed Storefront server with no stores created.

Resolution

There are 2 possible solutions to this:
  1. Create a test store, and run through the steps for importing the Storefront configuration. The test store that was created will be over-written, and the imported store configuration should not be present.
  2. Alternatively, if you specify the host base URL when importing the Storefront configuration into a blank Storefront server, it should import without any issue.

Problem Cause

Import of configuration was failing, as there was no existing store to import into.
Host base URL needs to be specified when importing config onto a black Storefront server