Synchronization State for WEM Agents shows question mark (?) on WEM Administration Console

Synchronization State for WEM Agents shows question mark (?) on WEM Administration Console

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Article ID: CTX229024

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Updated On:

Description

  • Synchronization State for WEM Agents shows a question mark (?) or red cross on the WEM Administration console.

Resolution

Configure the following script to be executed on every reboot for the WEM agents machines:

net stop “Citrix WEM Agent Host Service” /y
DEL "C:\Program Files (x86)\Citrix\Workspace Environment Management Agent\Local Databases\"*.db
TIMEOUT 5
net start “Citrix WEM Agent Host Service”
net start “Netlogon”
TIMEOUT 40
"C:\Program Files (x86)\Citrix\Workspace Environment Management Agent\AgentCacheUtility.exe" -refreshcache
 

Problem Cause

The agent cache refresh is having a delay to be executed to then synchronize with the WEM server.

Issue/Introduction

The only way for then to get the green check mark is by running the command to refresh the cache maually on each agent "C:\Program Files (x86)\Citrix\Workspace Environment Management Agent\AgentCacheUtility.exe -refreshcache".