Error: "Backup Failure: Could not find required XVA" on NetScaler SDX

Error: "Backup Failure: Could not find required XVA" on NetScaler SDX

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Article ID: CTX228895

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Updated On:

Description

After upgrading NetScaler SDX and Netscaler VPX firmware to any newer version you will get daily notifications about backups failing:
For Example the Log Message is as below:

<DATE> <Time> Local0.Error 10.xx.xx. <Date> <Time GMT> svm_event: <IP Address> <Date> <Time> GMT : EVENT BACKUPFAILED : 127.0.0.1:BackupFailure:<IP Address> - Could not find required XVA for <IP Address>

Resolution

To prevent this issue, you can follow either of the options:

  • Upload required NetScaler XVA file to SDX. The XVA file should be matching with current NetScaler VPX version. Here we are referring to the VPX that needs to be backed up.
  • Upload any NetScaler XVA file lower than current NetScaler VPX version (which is being backed up) and upload the required NetScaler upgrade image matching with current NetScaler version to SDX.

How to obtain the XVA file
  • Users can download the XVA image from the Citrix downloads portal: https://www.citrix.com/downloads/citrix-adc/virtual-appliances/ and navigate to the specific version and download.  The VPX XVA file is under the name "Citrix ADC VPX for Citrix Hypervisor".
  • User can upload the XVA and upgrade images (Software images) to SVM by navigating to pages: Configuration > NetScaler > Software Images.

Problem Cause

The XVA in the “/var/mps/xen_nsvpx_images/ directory” of SDX does not match the firmware version, which the VPX is upgraded to and running,

Issue/Introduction

After upgrading NetScaler SDX and VPX firmware you may get daily notifications about backups failing.