Unidesk - New desktops show black screens in VMware Horizon View

Unidesk - New desktops show black screens in VMware Horizon View

book

Article ID: CTX228881

calendar_today

Updated On:

Description

When connecting to a new desktop from the Horizon View client or a PCoIP Thin/ZeroClient, one or more monitors shows nothing but a black screen.

Environment

The above mentioned sample code is provided to you as is with no representations, warranties or conditions of any kind. You may use, modify and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that (a) the sample code may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the sample code fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the sample code. In no event should the code be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SAMPLE CODE, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Although the copyright in the code belongs to Citrix, any distribution of the sample code should include only your own standard copyright attribution, and not that of Citrix. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the sample code.

Resolution

To resolve this, simply power down the desktop or desktops. As long as the View pool is set to always keep desktops powered on then View will power back up the desktops after the reconfiguration has finished.

To automate this process a layer script can be set to automatically power down the desktop before the desktop creation task completes. This can be set on an app layer or the OS layer. To do this, add a version to the layer that you want to copy the script to. The new layer wizard will have a "Layer Script" field. Place the full path to the script there. For example "C:\Windows\Setup\Scripts\AutoShutdown.cmd" minus the quotes. This script will be run once and then deleted.

See the AutoShutdown.cmd script attached.

Problem Cause

When Unidesk creates a new desktop, it will only set one monitor and use the video RAM setting set from the gold image when it was imported into Unidesk. This is typically not enough as many deployments use two monitors or more and even with one monitor they may need more video RAM than was initially set in the gold image. All of these settings are changed by Horizon View per the pool settings. When a desktop completely powers down, View will check on its configuration. If it finds the desktops settings are out of spec per the pool settings then it will reconfigure the desktop to match those settings. Unidesk will reboot a new desktop multiple times during setup but it is never powered down which triggers this change.