Load Balancing Services flapping seen with VMWare - NetScaler Setup

Load Balancing Services flapping seen with VMWare - NetScaler Setup

book

Article ID: CTX228764

calendar_today

Updated On:

Description

  • Load Balancing services on NetScaler fluctuating.
  • Mac moves observed in the NSLOG.
  • Unable to reach the Backend Server due to service Monitor Probe fluctuating.
The following entries are seen in newnslog:
current time is Mon Jun  5 17:03:55 2017
Channel 0/1 has been muted (conflict MAC 00:1d:45:24:b3:68)
Channel 1/1 has been muted (conflict MAC 00:1d:45:24:b3:68)
current time is Mon Jun  5 17:39:18 2017
Channel 0/1 has been unmuted now
Channel 1/1 has been unmuted now
current time is Mon Jun  5 17:40:07 2017
AWS: Master Forcefail
current time is Mon Jun  5 18:16:29 2017
Channel 0/1 has been muted (conflict MAC 00:50:56:b9:74:b2)
Channel 1/1 has been muted (conflict MAC 00:50:56:b9:74:b2)
current time is Mon Jun  5 18:24:49 2017
Channel 0/1 has been unmuted now
Channel 1/1 has been unmuted now
current time is Mon Jun  5 18:24:56 2017

Resolution

Based on the extensive tests done on the setup:

There was one NetScaler on Hyper-V and another NetScaler on Vmware
There was an issue where while performing the Vlan Bindings on the Vmware for NetScaler , Mac address for the particular interface on NetScaler was not correctly seen on the Vmware dashboard.

Deleted and Created new setup of NetScaler on Vmware, still the same issue observed.

Created the new setup of both the NetScaler on Hyper-V and everything seems to be working fine.

Solution observed was as below:
  • No more Mac-Moves observed
  • No more Services fluctuating.
  • IP-Vlan binding to prevent the loops or Mac Moves
Please note: This is one of the examples seen on HA NetScaler Setup, it does not mean there is any problem/issue seen on Hyper-V / Vmware. Kindly contact Citrix Support for any questions if the above behavior is observed.
 

Problem Cause

Packets on Netscaler which was on Vmware is being changed to Hyper-V