NetScaler Gateway Client System Extension Gets Blocked on Newly Installed MacOS High Sierra (10.13)

NetScaler Gateway Client System Extension Gets Blocked on Newly Installed MacOS High Sierra (10.13)

book

Article ID: CTX228097

calendar_today

Updated On:

Description

If you install a fresh copy of Mac OS High Sierra on a new machine (not upgrade) and try to install NetScaler Gateway plugin for Mac, then you will see a popup indicating that the system extensions signed by "Citrix Systems Inc.” were blocked. 

User-added image

Even though you see the message that installation was successful, VPN connections to NetScaler Gateway will not work.

This issue doesn’t arise if you upgrade from older Mac OS to High Sierra because the extensions were already approved during the previous plug-in installation on older OS. 

Resolution

As per the suggestion in the popup, navigate to System Preferences > Security & Privacy and allow the blocked extensions. If the problem persists, re-install the plug-in.

Note: You might or might not get the registration blocked message.


Problem Cause

macOS High Sierra has introduced a new feature that prompts the user to approve new third-party kernel extensions.

Issue/Introduction

If you install a fresh copy of Mac OS High Sierra on a new machine (not upgrade) and try to install NetScaler Gateway plugin for Mac, then you will see a popup indicating that the system extensions signed by "Citrix Systems Inc.” were blocked.

Additional Information

https://developer.apple.com/library/content/technotes/tn2459/_index.html#//apple_ref/doc/uid/DTS40017658