TCP Ports get exhausted on the StoreFront server

TCP Ports get exhausted on the StoreFront server

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Article ID: CTX227903

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Updated On:

Description

StoreFront refuses to create connections and we get below events : 
 

  • Event ID 4231 : Request to allocate an ephemeral port number from the global TCP port space has failed due to all such ports being in use.
  • Event ID 4227 : TCP/IP failed to establish an outgoing connection because the selected local endpoint was recently used to connect to the same remote endpoint. This error typically occurs when outgoing connections are opened and closed at a high rate causing all available local ports to be used and forcing TCP/IP to reuse a local port for an outgoing connection. To minimize the risk of data corruption, the TCP/IP standard requires a minimum time period to elapse between successive connections from a given local endpoint to a given remote endpoint.

Environment

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Resolution

Update: This fix (LC8795) is included in the following releases:

  1. XenApp and XenDesktop 7.6 LTSR CU6  (StoreFront 3.0.6000.1)
  2. XenApp and XenDesktop 7.15 LTSR CU2 (StoreFront 3.12.2000)
  3. XenApp and XenDesktop 7.18  (StoreFront 3.15)

Disable Socket Pooling by unchecking the option at location : 

  • Configure Store Settings > Advanced Store Settings > Enable Socket Pooling

Another workaround is to recycle Application Pool of Citrix Delivery Services Resources periodically.


Problem Cause

When socket pooling is enabled, StoreFront maintains a pool of sockets, rather than creating a socket each time and returning it to the operating system when the connection is closed. 

Additional Information

http://docs.citrix.com/en-us/storefront/3-5/config-manage-stores/advanced-store-settings.html#par_anchortitle_a877

https://technet.microsoft.com/en-us/library/cc770764(v=ws.10)