Unable to access Worx Store and getting errors "could not load store"

Unable to access Worx Store and getting errors "could not load store"

book

Article ID: CTX227630

calendar_today

Updated On:

Description

  • On iOS Device while accessing store "cannot complete your request" error message.
  • On Android while accessing store getting error message while accessing store "could not load store"


SecureHub Logs

"2017-02-02T16:09:51.998+0400","SecureHub","ERROR ( 2)","com.citrix.work.featureflag.LaunchDarklyFeatureAgent:Failed to create user, return code: 202",18848,20210,Secure Hub, , ,0 
"2017-02-02T16:09:51.999+0400","SecureHub","ERROR ( 2)","com.citrix.work.featureflag.LaunchDarklyFeatureAgent:FeatureToggle: LaunchDarkly createUserNetworkRequest failed:: 
java.lang.Exception 
at com.citrix.work.featureflag.LaunchDarklyFeatureAgent.createBulkEventUploadRequest(LaunchDarklyFeatureAgent.java:412) 
at com.citrix.work.featureflag.LaunchDarklyFeatureAgent.fetchFlags(LaunchDarklyFeatureAgent.java:90) 
at com.citrix.work.featureflag.FeatureFlagController.getAllFeatureFlags(FeatureFlagController.java:54) 
at com.citrix.work.featureflag.FeatureFlagJob.onRunJob(FeatureFlagJob.java:30) 
at com.evernote.android.job.Job.runJob(Job.java:109) 
at com.evernote.android.job.JobExecutor$JobCallable.runJob(JobExecutor.java:150) 
at com.evernote.android.job.JobExecutor$JobCallable.call(JobExecutor.java:135) 
at com.evernote.android.job.JobExecutor$JobCallable.call(JobExecutor.java:118) 
at java.util.concurrent.FutureTask.run(FutureTask.java:237) 
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1113) 
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:588) 
at java.lang.Thread.run(Thread.java:833) 
",18848,20210,Secure Hub, , ,0 
 

Resolution

  • Verify if the LDAP policy on Netscaler to pointing to the correct LDAP server IP.
  • Verify the LDAP ports is open between NetScaler and LDAP server (636 or 389). 
  • Remove the xms FQDN and re-add under the allowed domains for configure domains for clientless access (xmsfqdn:8443).
  • Under the NSG policies > clientless access policies.
 ○ Verified the expression for the first policy should be "HTTP.REQ.HEADER("User-Agent").CONTAINS("CitrixReceiver") && HTTP.REQ.HEADER("X-Citrix-Gateway").EXISTS"
§ Under rewrite tab should be empty - Removed the URL rewrite
§ The finding url tab should be empty
§ Also the client cookies should be empty

○ For the second policy the policy expression was TRUE
§ Under rewrite tab - Verified the URL rewrite should be "ns_cvpn_default_inet_url_label" § The finding url tab was empty
§ There were no Client cookies added , hence added the Client Cookies and under that add the following pattern with the respective index
□ CsrfToken 1
□ ASP.NET_SessionId 2
□ CtxsPluginAssistantState 3
□ CtxsAuthId 4 Changed the persistence method to Source IP under MAM LB VIP
  • Apply XMS 10.6 Rolling Patch 2 has fix for the same issue.

Problem Cause

Issues with the Netscaler Gateway configuration and in known issue list

Issue/Introduction

This article summarizes the steps to verify if users are unable to access store and get "could not load store "