WEM agent is not able to connect/synchronize with the WEM Broker Server

WEM agent is not able to connect/synchronize with the WEM Broker Server

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Article ID: CTX227544

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Updated On:

Description

ISSUE:
WEM Agent is not able to connect and synchronize with the WEM Broker server(s)

ERRORS PRESENT:
The WEM Agent session & Debug logs show the following error:
Exception -> AgentLocalCacheSync.() : The communication object, System.ServiceModel.Channels.ServiceChannel, cannot be used for communication because it is in the Faulted state. 
Checked the service account used by the broker service. 


Inside of the Event Viewer log named "Norskale Broker Service" on the WEM broker server, the following error is present:
" The EXECUTE permission was denied on the object GetVUEMADObject', database 'WorkspaceManager', schema 'dba', at exception, Boolean breakConnection"
 

Resolution

Added the proper permissions to the WEM Database for the Service account being used to run the Norskale Infrastructure Service on the WEM Broker server(s):
Per Citrix docs via this link:  Citrix Documentation - System requirements

Microsoft SQL Server 2008 R2 or later: Workspace Environment Management requires sysadmin access to a SQL Server instance to create its database, and read/write access to this database to use it.

 


Problem Cause

Inappropriate permissions for Service Account used to connect to the WEM Database.