Citrix Desktop service is not running or installed on the VDA

Citrix Desktop service is not running or installed on the VDA

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Article ID: CTX227530

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Updated On:

Description

VDAs will show as unregistered in Studio

 

Resolution

To resolve this issue:

  1. Launch the Services console: Click Start and then type Services
  2. Verify the Citrix Desktop Service is present, restart the service, and check the Event Log for any errors: From the Services console, right-click the Citrix Desktop Service and select Restart
  3. Verify the service's Startup Type is set to Automatic. If not, right-click the service, select Properties, and then, in Startup type, select Automatic
  4. Verify that the service is configured to run under the Network Service account.
  5. If the Citrix Desktop Service is not present or you are still receiving this alert after performing the previous steps, you might need to repair the VDA installation or reinstall the VDA software. See Before doing this, verify the Print Spooler service is running on the machine.
    Note: The Print Spooler service is required for successfully installing the VDA software for Windows Server operating systems. If the Print Spooler service is stopped, right-click the service and select Start

Problem Cause

VDA Registration fails due to the Citrix Desktop service is not running, properly installed, or the service permissions might not be set correctly. This issue can occur if the service is not started or the system Event Log has traces of service related issues.


Note: If the Citrix Desktop Service is not present or running, the VDA can't register with the Site, preventing users from accessing their applications and desktops.

Additional Information

Use the Citrix Health Assistant to troubleshoot issues like this, it will help you with solutions to most common registration errors