VDA Showing Unregistered in Studio due to Port Availability

VDA Showing Unregistered in Studio due to Port Availability

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Article ID: CTX227521

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Updated On:

Description

 VDAs are showing as unregistered in the Studio Console

Resolution

To resolve this issue, preview the ports currently in use in the Site and verify they are not being used by other applications. Also, there should be no issues with bi-directional telnet communications between DDC and VDA.  If needed, resolve port conflicts to ensure the ports are available for the VDAs to use:

1.    Open a command line window on the VDA
2.    Type in <netstat –ano | find “:serviceport”>  (where serviceport is the portnumber being used, for example :80)

C:\>netstat -ano |find ":80"
  TCP 192.168.0.115 61311 186.6.57.55:80 ESTABLISHED 1584
 TCP 192.168.0.115:61351 186.6.57.55:80 ESTABLISHED 1584
  
  
3.    In the output, the last column represents the process id that is using the port
4.    In the example above, process 4 and 1584 are using the port 80
5.    Use tasklist to find the process using port 80

C:\>tasklist |find "1584"
Httpd.exe 1584 Console 1 132,242 K
  
6.    In this case,  Apache server is using the process
7.    Decide if you want to stop the process or reconfigure the application in use to use another port. 

To test telnet connectivity follow these steps on both the VDA and DDC:

In an admin powershell window run the following command.  It should return true if communication is successful:

PS C:\Test-NetConnection -ComputerName "DDC.citrix.com" -Port 80

Alternatively, if you have Telnet installed you can run the following command within a command prompt window:
telnet [FQDN or IP] [port]  
ex. telnet "ddc.citrix.com" 80

 


Problem Cause

The following ports needs to be available for VDAs in the Site to use in order for successful registration and session launch:
  • Registration TCP port (80)
  • ICA TCP port (1494)
  • XTE TCP port (2598)
  • HTML5 TCP port (8008) - Only required for web access
  • SSL TCP port (443)
  • AudioRTP UDP ports (16500-16509)
  • Spyder ICA UDP port (1494)
  • Spyder XTE UDP port (2598)
VDAs in the Site use these ports to provide access to applications and desktops. If other applications are using these ports, users might not be able to launch sessions and access their applications and desktops.

For a complete list of App and Desktop ports, refer to Communication Ports Used by Citrix Technologies

Additional Information

Use the Citrix Health Assistant to help troubleshoot issues like this.