"Unknown Client Error 1110" error when launching Desktop using Firefox

"Unknown Client Error 1110" error when launching Desktop using Firefox

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Article ID: CTX227354

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Updated On:

Description

  • When launching a desktop, user might get an "Unknown Client Error 1110" error
  • The error is appearing only when using the Firefox browser to connect to the gateway. If used with other browsers, desktop is launching properly.
  • If the ICA file is saved to the disk prior to launch, the desktop enumeration is happening as expected

Resolution

Update: This has been fixed in Citrix Receiver for Windows 4.9 LTSR CU1 and later.

Source code fix has been implemented in DesktopViewer.dll file.

Citrix is aware of this issue and will fix it in an upcoming version of Receiver.

A workaround is to save the ICA file to the disk every time prior to launching it, or to delete the ICA files from system TEMP folders before launching the app:

  • C:\Users\<username>\AppData\Local\Temp
  • C:\Users\<username>\AppData\Local\Microsoft\Windows\INetCache\ (Windows8 / 10)
  • C:\Users\<username>\AppData\Local\Microsoft\Windows\Temporary Internet Files\Low\Content.IE5 (Windows7)

Problem Cause

Direct cause of the issue is the Receiver re-using the .ica file from the previous session. 
This is happening because Desktop Viewer can't delete the previously created .ica file from the browser’s temp directory, which blocked the .ica file copy for the next session launch. 
The .ica file in the temp directory has read-only attribute inheriting from its parent directory. 

Desktop viewer is not able to delete the previously created .ica file from the IE temp directory, an access denied error was returned, which blocks the ica file copy for the next session launch.
The .ica file in the temp directory has read-only attribute inheriting from its parent directory.