RemotePC Connection Fails With Error 1030 on XenDesktop 7.x

RemotePC Connection Fails With Error 1030 on XenDesktop 7.x

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Article ID: CTX226744

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Updated On:

Description

When customer attempts to launch a RemotePC connection, the connection fails with a 1030 error. VDA side CDF trace shows that the PrepareSession succeeded but there was no incoming session request from the client. 

Environment

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Resolution

Try one of the following solutions:

1. Turning off System wide proxy - Internet explorer > Tools > Internet Options > Connections tab > Uncheck "Use Automatic Configuration Script" Or Uncheck the Proxy Server specified > Click OK.

2. Set ProxyType to None in the Default.ica file.

The overall goal is to bypass the proxy for the remote PC connection. Depending on the type of proxy server, there might be configuration that would help to create rules to allow Remote PC traffic through the proxy as well. Refer to the proxy software documentation for more information.

Problem Cause

McAfee Web Gateway configured as proxy on the client Internet explorer was blocking the ICA connection request reaching to the VDA. This could potentially be caused by other proxies as well. 

Issue/Introduction

When customer attempts to launch a RemotePC connection from a client machine, the connection fails with a 1030 error. Same connection attempt initiated from the Storefront server succeeds.