CitrixBrokerService event 1152 after importing additional license file
book
Article ID: CTX226455
calendar_today
Updated On:
Description
After importing additional license file on license server, following license related messages might outputted by Citrix Broker Service:
EventID 1152
Message:
This XenDesktop site does not have the required product licenses present on the license server 'xxxx'.
Please use the License Administration Console to add the relevant product licenses to the license server.
EventID 1151
Message:The Citrix Broker Service cannot contact the license server 'xxxx'.
Please ensure that the license server is functioning correctly and that the details identifying the license server are correct in the XenDesktop configuration.
EventID 1154
This controller has entered an emergency licensing grace period because it could not contact the license server '720'.
You have %2 hour(s) remaining before this controller stops providing desktop and application sessions.
Resolution
Please check if following messages are outputted by Citrix Broker Service after above error/warining:
EventID 1150
Message:The Citrix Broker Service successfully contacted the license server 'xxxxxxxx'.
EventID 1156
Message:The Citrix Broker Service is successfully communicating with the license server 'xxxxxxxx'. This controller is no longer in an emergency licensing grace period.
If yes, that means Citrix Broker Service successfully communicating with license server, and above error/warining can be safely ignored, no action needed.
Problem Cause
Citrix product and the License Server exchange "heartbeat" messages every five minutes to indicate to each other that they are still up and running. In case of heartbeat occurs before Citrix license Server load newly imported license, Event ID 1154 and etc may get outputted.
Additional Information
Events indicating Citrix Broker Service successfully communicating with license server may get outputted some time (2 hours) later.
Was this article helpful?
thumb_up
Yes
thumb_down
No