XA 7.7: Windows 10 users can't launch apps

XA 7.7: Windows 10 users can't launch apps

book

Article ID: CTX226354

calendar_today

Updated On:

Description

When users launch published Outlook application from Win 10 client machines, it crashes the application. We also noticed that only Outlook 2013 is affected and other applications are launching correctly.
Word, excel, powerpoint works fine. 

Environment

Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.

Resolution

Please install newer .net framework as available at
https://support.microsoft.com/en-in/help/4022716/windows-10-update-kb4022716
If this does not fix, we may have to revert to an older version of .NET Framework.

Problem Cause

Outlook is terminated as a result of exception created looking for .NET related dll "penimc.dll" 

Additional Information

https://support.microsoft.com/en-us/help/4014604/may-2017-description-of-the-quality-rollup-for-the-net-framework-4-6-4 
https://developercommunity.visualstudio.com/content/problem/55303/visual-studio-may-terminate-unexpectedly-when-runn.html 
https://support.microsoft.com/en-in/help/4022716/windows-10-update-kb4022716