Case Study: Unable to retrieve application/process list of a user session in Director

Case Study: Unable to retrieve application/process list of a user session in Director

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Article ID: CTX226274

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Updated On:

Description

After launched an ICA session, customer found in Citrix Director "Activity Manager" panel, neither Applications nor Processes tab is able to display but withe error message "Cannot retrieve the data". Meanwhile, Citrix Director Service will log Event ID 5, indicating 'Failed to execute broker synchronous command=GetRunningApplications'.
User-added image
In further troubleshooting, CDF trace indicates the issue was triggered by a Microsoft DCOM exception, "The server process could not be started because the configured identity is incorrect. Check the username and password. (Exception from HRESULT: 0x8000401A)"​.

Resolution

Exit any Non-Citrix process that modifies entries under "HKLM\SOFTWARE\Citrix\ICA\Session\CTXSessions" to ensure DirectorComServer.exe succeeds to run. To find out existence of such process, you may use tools like ProcessMonitor.

Problem Cause

The issue occurrence logic is figured out as below,
  1. Retrieving application or process list of an ICA session depends on Citrix DirectorComServer.exe running inside VDA.
  2. However, in this case, a Non-Citrix process running in the affected VDA cleaned entries under HKLM\SOFTWARE\Citrix\ICA\Session\CTXSessions after ICA session establishment
  3. As the entry representing current ICA session got deleted, Windows DCOM server process launcher failed to run DirectorComServer.exe as "This interactive user" with DCOM Exception 0x8000401A.

Issue/Introduction

The article describes an issue of retrieving app/process list of a user session in director.

Additional Information

HRESULT Values: https://msdn.microsoft.com/en-us/library/cc704587.aspx

0x8000401A

CO_E_RUNAS_LOGON_FAILURE

The server process could not be started because the configured identity is incorrect. Check the user name and password.