Application Shortcuts disappear when connecting to server where the profile already exists

Application Shortcuts disappear when connecting to server where the profile already exists

book

Article ID: CTX225949

calendar_today

Updated On:

Description

When first logging into a server and the user profile is created for the first time, application shortcuts as configured in WEM appears on Desktop.

***Application shortcuts configured in WEM:***
User-added image


Shortcuts created on desktop of new user profile:

User-added image


Shortcuts deleted after subsequent logins

User-added image
 

Resolution

  1. Launch WEM Administration Console and connect to your site
  2. Click Actions > select Applications
  3. Right click on the Application and click edit.
  4. ***If the application is already assigned, you will see a warning letting you know.....simply click "Yes"***
  5. Click on the tab titled "Advanced Settings"
  6. Place a Checkmark in "Enable Automatic Self-Healing" and click OK.

****Possible Alternate Solution:
If Cleanup Actions are being used to delete Desktop Shortcuts, enable "Enforce..." settings:
-These options are present inside the WEM Administration Console under Advanced Settings  > Configuration (Under 2 tabs named "Cleanup Actions" & "Advanced Options")

 

Problem Cause

Application shortcuts were being deleted by clean up settings configured in WEM.