Error: Secure Hub - Couldn't Load Store

Error: Secure Hub - Couldn't Load Store

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Article ID: CTX225598

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Updated On:

Description

There are two scenarios in which this error might occur
1) While performing a new enrollment.
2) Tapping on Store for a already enrolled user. 

Resolution

Possible causes:
  1. Check if the NetScaler Gateway is up.
  2. Check if the STA for XMS is up on the NetScaler Gateway.
  3. Check if the MAM LB VIP is resolvable. You may need to add a DNS entry for the MAM LB VIP FQDN
  4. Go to Netscaler Gateway -> Global Settings -> Configured Domains for Clientless Access to Allowed Domains.
  5. Add the XM Server FQDN (mdm.domain.com:8443) in Domains for Clientless Access to Allowed Domains.
  6. In some cases if you see only a specific user unable to access the store while other can- then check if the device or user has duplicate MAM ID entries in the Database. More information on duplicate MAM entries is available in below article : https://support.citrix.com/article/CTX217692
Note : Duplicate MAM ID issue was resolved with XMS 10.3.6 , however, if you still see the issue report it back to support.

Issue/Introduction

Secure Hub - Couldn't Load Store