"Trust Service Schema” error while upgrading to 7.13 or 7.14"

"Trust Service Schema” error while upgrading to 7.13 or 7.14"

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Article ID: CTX224599

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Updated On:

Description

When upgrading XenApp or XenDesktop to 7.13 or 7.14, upgrade fails during the upgrading of the Site DB (“Start the automatic Site upgrade” operation in Studio). The error details are:
Error Id: XDDS:CDCD0D84
 

Resolution

  1. Confirm that the issue is due to Trust Service DB Connection not being set.
    Get-TrustDBConnection should return an empty result and Get-TrustServiceStatus should return a ServiceStatus of “DBUnconfigured”.
  2. Get a DB connection string from another Citrix Trust Service.  This is usually safe as most cases, the DB Connection string is the same for all Citrix FMA Services. 
    $db = Get-ConfigDBConnection
    You would have had to take extra steps to have them not all be the same in which case you should know how what the proper DB Connection string is.
  3. Set Trust service DB Connection string.
    Set-TrustDBConnection -DBConnection $db
  4. Repeat steps 1-3 on all DDCs and once done, perform the last step on one DDC.
  5. Restart Studio and redo the Site Upgrade. CTX224599

Problem Cause

Customers who deployed XenApp/XenDesktop 7.11 Delivery Controller and upgraded subsequently to XenApp/XenDesktop 7.12 or 7.13 will encounter this issue when upgrading to XenApp/XenDesktop 7.14. During the upgrade to XenApp/XenDesktop 7.14, a registry key that contained the Trust FMA Service’s Database Connection string was deleted. As a result, the Citrix Trust Service running on the Delivery Controller is unable to access the database after the upgrade. Citrix Studio fails to complete a site upgrade when the Trust Service is not connected to the database.