Seamless application window incomplete display in Dual-Monitor Windows 10 client

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Article ID: CTX224400

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Updated On:

Description

Customer launched a seamless application in a Dual-Monitor Windows 10 client. However, half of the application window is filled with black image.

Resolution

Follow below steps to fix the issue,
  1. Logoff all ICA session and exit Receiver
  2. Navigate to C:\Program Files (x86)\Citrix\ICA Client\
  3. Locate wfica32.exe and right-click it, choose Properties -> Compatibility-> Change High DPI Settings - Check the Override high DPI scaling behavior and ensure that the Application option is selected.
  4. Click OK
  5. Repeat step 3 for wfcrun32.exe

Problem Cause

Seamless display issue in high DPI

Issue/Introduction

The article describes a seamless window display issue in Dual-Monitor Windows 10 client

Additional Information

Surface Pro 3 external display and Citrix XenApp: https://community.spiceworks.com/topic/663199-surface-pro-3-external-display-and-citrix-xenapp

https://support.microsoft.com/en-in/help/3025083/windows-scaling-issues-for-high-dpi-devices

Versions of Citrix Receiver for Windows 4.10 and higher are now "DPI scaling aware", and provide improved support for handling higher DPI resolution in a session. To learn more about high DPI scaling, please visit the following links -