Microsoft Office Activation fails when Citrix VDA 7.9 or above is installed

Microsoft Office Activation fails when Citrix VDA 7.9 or above is installed

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Article ID: CTX223973

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Updated On:

Description

When we install VDA 7.9 or above, the Microsoft Office activation fails with an error “Microsoft Office can’t find your license for this application. A repair attempt was unsuccessful or was cancelled. Microsoft Office will now exit.”
The Software Protection fails to do a trigger start and starting the service manually resolves the issue.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Exclude the Software Protection Service from Citrix Hooking by following the below steps to resolve the issue
  1. Open Regedit on the VDA
  2. Go to [HKLM\SYSTEM\CurrentControlSet\services\CtxUvi].
  3. Now on the Right hand pane create a String Value “UviProcessExcludes”
  4. Now right click on the key, modify and add sppsvc.exe
  5. Reboot the server and let us know if you are still seeing the issue with Office Activation.
Note: The Registry Key is part of VDA 7.14 Release, you need to just add the Sppsvc.exe to registry to resolve the issue starting 7.14.

Problem Cause

Starting VDA 7.9, we issue kernel APC to hook into the process. The issue was caused by KAPC hook on the SPPSVC.exe service

Issue/Introduction

When we install VDA 7.9 or above, the Microsoft Office activation fails with an error “Microsoft Office can’t find your license for this application. A repair attempt was unsuccessful or was cancelled. Microsoft Office will now exit.”