Average Logon Duration Is Not Available In Citrix Director
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Article ID: CTX223972
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Description
- When an administrator logs in Citrix Director and goes to "trends" to look for Average Logon Duration, the information is not available.

- Logon Duration in MonitorData.Session Table in Monitoring Database also shows "Null" value for "Logon Duration"
- Restarting the Monitoring Service on Delivery Controllers does not fix the issue.
Resolution
Check WMI Object on the VDA:
- Logon duration collection is calculated using data collected at the VDA and the Broker. On the VDA side, it relies on the UPM WMI provider. We ran the below Powershell cmdlet to check if Citrix Profile Manager is getting the information form the Citrix Profile Manager WMI provider or not and in this case we did not get any output.
get-wmiobject -namespace root\citrix\profiles\metrics -class logontimings
- We confirmed that the Citrix Profile Manager is installed on the VDA but the Citrix Profile Management Service was stopped.
- After starting the Citrix Profile Management Service on the VDA and Citrix Monitoring Service on the Delivery Controller, the Average Logon Duration was visible in Director.
Problem Cause
Citrix Profile Management Service was stopped on the VDA's.
Issue/Introduction
Average Logon Duration Is Not Available In Citrix Director
Additional Information
Logon time requires Citrix Profile Management service to be installed and running. In order for VDA to pull the User Logon Information, Citrix Profile Manager needs to be installed on the VDA and the service needs to be started even if you are not using User profile Management for managing user profiles.
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