Citrix Virtual Apps and Desktops, formerly XenDesktop, fits the enterprise need to bring both VDI and apps into a user-centric experience.
Citrix Virtual Apps, formerly XenApp, fits the enterprise need to bring legacy apps into a cloud management environment.
Microsoft releases software updates for Windows 10 periodically. On April 11 2017, Microsoft has released its latest update for Windows 10 called Creators Update (v1703). Some of the known issues of this update with Citrix XenDesktop and XenApp in conjunction with the following listed Citrix products and known workarounds for respective issues are listed below:
Citrix Virtual Delivery Agent (VDA) for Windows Desktop OS 7.x
Citrix Receiver for Windows
Note:
This is a live article, and is updated as and when new information becomes available.
Microsoft has fixed some of the update issues that were seen with previous Windows 10 Anniversary Update. Issues 1 through 4 listed in article CTX216312 are not experienced with Windows 10 Creators Update.
The following are the known issues:
Issue 1
Full screen sessions hides the PIN prompt window. The Windows Security and UAC prompt are updated from Winform to XAML. This causes the PIN prompt window to lose focus and stay in the background.
Issue 2
Issue Description
Printer redirection fails when Creators Update (v1703) is applied to Windows 10 v1507/v1511/v1607 machine with Citrix VDA for Windows Desktop OS installed.
Problem Cause
Printer auto-creation failure. Reason: AddPrinter() failed with status 0x5. During upgrade to v1703, a new print spooler is installed and old permissions are lost. This issue is not experienced if Citrix VDA for Windows Desktop OS is installed for the first time on a machine already running Windows 10 Creators Update (v1703).
Solution
Administrator can download attachment.zip and run FixCpsvcSpoolerPermission.exe which resets the permissions. Follow below steps:
[HDX-9959]
Problem Cause
Monochrome custom cursors created via CreateCursor() in a non-DPI aware application do not scale correctly with Windows 10 v1703 and later versions. Custom cursors created via CreateInconIndirect() in a non-DPI aware application do not scale correctly in all versions of Windows 10.
Issue Description
Mouse cursor is distorted or may disappear at times when published application or VDA is launched in full screen on multi monitor setup with high DPI/Resolution.
[RFWIN-7040]
Problem Cause
Monochrome custom cursors created via CreateCursor() can be distorted on multi monitor setups with mixed DPI in Windows 10.
Solution
Issue Description
Published Application/desktop launch may fail with SSL error 4 message when using Smart card authentication through a NetScaler environment on Windows 10 1703 (creator update) client.
Solution
Microsoft has released security update KB4038788 containing the fix for issue. Applying this update on the Windows 10 v1703 endpoint will resolve the issue.
Issue 6
Issue Description
Citrix Desktop Lock feature of Citrix Receiver fails to work when Windows 10 is upgraded to v1703
[TPV-744]
Problem Cause
During the Operating System upgrade, under [HKLM -> SOFTWARE -> Microsoft -> Windows NT -> CurrentVersion -> Winlogon] the value for Shell is getting restored to default value of explorer.exe
Solution
Citrix is working with Microsoft to resolve the issue. As a workaround, user may manually update the registry key by following below steps:
Caution! Refer to the Disclaimer at the end of this article before making changes to Registry
Right click on Start button and choose Run
Type ‘Regedit’ and click Ok.
On x86 machine, browse to HKEY_LOCAL_MACHINE -> Software -> Microsoft -> Windows NT -> CurrentVersion -> Winlogon
On x64 machine, browse to HKEY_LOCAL_MACHINE -> Software -> WOW6432Node -> Microsoft -> Windows NT -> CurrentVersion -> Winlogon
On the right pane, right click on ‘Shell’ and choose ‘Modify’.
On x86 machine, replace the value ‘explorer.exe’ to ‘C:\Program Files\Citrix\ICA Client\SelfServicePlugin\selfservice.exe’ and click Ok.
On x64 machine, replace the value ‘explorer.exe’ to ‘C:\Program Files (x86)\Citrix\ICA Client\SelfServicePlugin\selfservice.exe’ and click Ok.
Right click on Winlogon in left pane, choose New -> String Value
Enter the value as ‘CtxBackUpShell ’ and hit enter.
Issue 7
Issue Description
Citrix Workspace Environment Management (WEM) Agent fails to work when Windows 10 is upgraded to Windows 10 v1703.
[TPV-1184]
Problem Cause
The registry key ‘Norskale’ under [HKLM -> System -> CurrentControlSet -> Control] is removed during the upgrade to Windows 10 v1703.
Solution
Citrix is working with Microsoft to resolve this issue. To restore functionality, users could uninstall WEM Agent on the upgraded machine, reinstall and reconfigure.
Issue Description
Some maximized applications in Local App Access(LAA) enabled desktop sessions cannot be minimized using the minimize button. (Example application: Notepad, CMD)
[LC8813]
Problem Cause
The issue is due to an incorrect function call getting triggered for LAA enabled desktops.
Solution
This issue is resolved in Citrix XenDesktop 7.18 and CU2 for XenDesktop 7.15.