PVS Targets run chkdsk at boot after the vDisk has been modified

PVS Targets run chkdsk at boot after the vDisk has been modified

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Article ID: CTX222937

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Description

Every time a PVS Target Device boots from a vDisk the OS detects problems with the C: drive and automatically runs chkdsk at boot time.

The following events might be observed in the Windows Event Log on the Target Device:

Event Log: System
Source: Ntfs
Event ID: 55
Text: The file system structure on the disk is corrupt and unusable. Please run the chkdsk utility on the volume System.

Resolution

Using one of the Target Devices boot to the vDisk in Read/Write mode.

To change the vDisk to Read/Write mode use one of the following methods:
1. Change the vDisk to Private Mode on the PVS Console
    Note: This process will require that all the Target Devices currently using the vDisk be shut down. This method will require down time
2. Create a Maintenance Version on the vDisk, using the PVS Console, and boot a Target Device configured for Maintenance Mode and with this vDisk assigned

If the Operating System runs chkdsk automatically at boot time, let it finish the process and reboot.
Depending on the File System problems found by the Operating System, chkdsk might run several times at boot and will require several reboots.

After the Target Device has been able to boot 2-3 times without prompting to run chkdsk, change the vDisk back to Read/Only mode and deploy to the Production Targets.
 

Problem Cause

This behavior is very uncommon and should not be caused by the PVS Software.

There are countless environmental variables that can lead to this behavior, including third party software that could corrupt the NTFS file system
Any potential cause for this behavior on a NON-PVS machine can also be a cause for the behavior in a PVS vDisk.

It is a common practice to have "sealing scripts" that perform last minute cleaning actions on a vDisk, before changing the vDisk to Read/Only mode.
As a  troubleshooting step, temporarily disable any "sealing scripts" or cleanup actions, including Anti Virus scans, before changing the vDisk to Read/Only mode.

The issue needs to be treated as an Operating System issue that is not related to the PVS software.