License count is incorrect on XMS console
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Article ID: CTX222600
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Updated On:
Description
We see consumed licenses on XMS console under Licensing tab is more while the total number of enrolled devices is less (pulled a report from XM).
The license file has been re-read on the licensing server and there is no change.
Environment
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Resolution
For instance in case we see any difference between the license count on XMS server and Licensing server
OR
Sometimes the license count shows up more than the actual number of devices enrolled.
Follow the below steps to check the information:
1. Log on to the Windows server for the licensing server
2. Run the cmd prompt
3. Navigate to the Citrix Folder followed by Licensing/LS directory
4. Run the udadmin -list command to see all the devices which are consuming the licenses
5. Now compare the licenses under the dbo.license_user_info table if the licenses are user based or the dbo.license_device_info for device based and compare if there any unwanted license entries.
6. To release the additional licenses, please use this command
Udadmin -f XDT_ENT_UD -device <device ID/ MAM ID> -delete
Udadmin -f XDT_ENT_UD - user <userid> -delete
The XDT_ENT_UD is the feature that will be displayed when you run the list command as in step 4.
Repeat Step 6 for all the entries you want to remove.
Problem Cause
Sometimes, there are additional entries which comes up during migration or upgrade.
Some historical data presents in DB.
Issue/Introduction
The number of licenses consumed on XenMobile console shows more than the actual number of devices enrolled. The licensing server also shows up incorrect count when compare with the number of devices enrolled. License file has been re-read in the License server.
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