XenDesktop 7.12 - Studio gets Stuck in Mandatory Upgrade loop

XenDesktop 7.12 - Studio gets Stuck in Mandatory Upgrade loop

book

Article ID: CTX222562

calendar_today

Updated On:

Description

User-added image

After upgrade from previous versions or a fresh install of 7.12 Controller causes Studio to be Stuck in Mandatory upgrade loop.

This issue seems to affect only those customers who have FIPS enabled on the VM/DDC where Studio is installed.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

As a workaround FIPS can be disabled under "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\FIPSAlgorithmPolicy"

If we need to use FIPS, a support case needs to be created to get a private fix for XenDesktop/XenApp 7.12.
                                                                   OR
The public fix for this issue is a part of XenApp and XenDesktop 7.13 and can be downloaded from here.

Problem Cause

The issue happens as the analytics service in 7.12 does not interpret FIPS validated cryptographic algorithms.

Additional Information

https://www.citrix.com/content/dam/citrix/en_us/documents/about/citrix-xenapp-and-xendesktop-76-fips-140-2-sample-deployments.pdf