ICA Connection Fails To Start Through Receiver for Web

ICA Connection Fails To Start Through Receiver for Web

book

Article ID: CTX221707

calendar_today

Updated On:

Description

This article is intended for Citrix administrators and technical teams only.

Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.

ICA connections fail to start from web browser. Problem appears after launch.ica file is delivered and executed by Receiver. Upon execution of launch.ica file, application launch status windows are not presented. From user perspective it looks as nothing is happening when application is clicked.

Resolution

  1. Open Procmon or ProcExplorer.
  2. Locate Browser in process list.
  3. Add "Integrity" column in process view.
  4. Compare Integrity level of Internet Explorer and Receiver Process.
  5. If integrity levels are different, processes may have problem with COM communication and as result fail to establish communication.

    User-added image

  6. To recover from this issue, make sure that processes are started on same integrity level, verify user launching process, ACL, possible startup scripts running in different user context.

Problem Cause

Browser process was launched with logon script in privileged mode where as wfica32.xe was launched at medium integrity level. This lead to COM access issue and failure.

More information about Windows Integrity mechanism can be found at:
https://msdn.microsoft.com/en-us/library/bb625957.aspx
https://msdn.microsoft.com/en-us/library/bb625962.aspx
https://msdn.microsoft.com/en-us/library/bb625963.aspx
 

Issue/Introduction

ICA Connection Fails To Start Through Receiver for Web