"Connection Interrupted" error message displayed while logging off ICA session

"Connection Interrupted" error message displayed while logging off ICA session

book

Article ID: CTX221206

calendar_today

Updated On:

Description

Intermittently during a logoff from a XenDesktop session, a blank desktop is presented with a message that the connection was interrupted, and that Citrix Receiver tries to reconnect.
User-added image

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Solution 1: Follow the below steps to identify the driver causing the problem.

1. On the VDA, where the issue is happening, run elevated Command Prompt.
2. Run the command fltmc to see all the filter drivers loaded on the VDA.
3. Check if you have any drivers named TDx.sys. (where 'x' is a wild card, so it could be anything like TDabc.sys, TDxyz.sys or so)
4. Disable that filter driver one by one using "sc config "TDx.sys" Start=disabled" command.
5. Once disabled, you should not see the "Connection Interrupted" anymore.

Solution 2:

Uninstall existing VMWare Tool
Download VMWare Tool version 10.3.5 and install excluding SVGA Driver.

User-added image

 

Problem Cause

List of drivers which have been identified to cause this issue but are not limited to are:

C:\WINDOWS\SYSTEM32\DRIVERS\TMTDI.SYS
- C:\WINDOWS\SYSTEM32\DRIVERS\AKSDF.SYS
- C:\WINDOWS\SYSTEM32\DRIVERS\AKSFRIDGE.SYS
- C:\WINDOWS\SYSTEM32\DRIVERS\BXVBDA.SYS
- C:\WINDOWS\SYSTEM32\DRIVERS\BXVBDA.SYS
- C:\WINDOWS\SYSTEM32\DRIVERS\B57ND60A.SYS
- C:\WINDOWS\SYSTEM32\DRIVERS\EVBDA.SYS
- C:\WINDOWS\SYSTEM32\DRIVERS\RTNIC64.SYS
- C:\WINDOWS\SYSTEM32\DRIVERS\LDSECDRV.SYS
- C:\WINDOWS\SYSTEM32\DRIVERS\NETGUARD.SYS
- C:\WINDOWS\SYSTEM32\DRIVERS\VNETFLT.SYS
- C:\WINDOWS\SYSTEM32\DRIVERS\VSEPFLT.SYS
- C:\WINDOWS\SYSTEM32\DRIVERS\neofltr_803_30597.sys
--------------------------------------------------------------------------------------------
Deprecation information for TDI, vendors providing their solutions should be using Windows Filtering Platform or Winsock Kernel which are fully supported by now.

 
https://msdn.microsoft.com/en-us/library/windows/hardware/ff565094(v=vs.85).aspx
https://technet.microsoft.com/en-us/library/cc939977.aspx
https://technet.microsoft.com/en-us/library/hh831568(v=ws.11).aspx
https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2121307
 
Windows Server 8.1 and 2012 R2 upwards will flag these drivers with an event id 16001 in the System log from source AFD that reads:
A TDI filter (\Driver\<name>) was detected. This filter has not been certified by Microsoft and may cause system instability

------------------------------------------------------------------------------------------------

 

Issue/Introduction

Intermittently during logoff from a XenDesktop session a blank desktop is presented with a message that the connection was interrupted, and that Citrix Receiver tries to reconnect. This issue doesn’t affect all customers upgrading to 7.12, 7.13 and 7.14.