Error: "No Audio Available, Could Not Open An Audio Device For Playback" In ICA Session
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Article ID: CTX220885
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Updated On:
Description
XenApp 7.6 - Audio is not working in ICA. Error message is: "No audio available. Could not open an audio device for playback. Automatic audio device detection failed. Audio playback will not be available during this session.

Resolution
Complete the following steps on Win 7 and 2008 R2.
- First check if RDP- Tcp and ICA- Tcp does not have audio disabled. Go to Administrative tools-> Remote Desktop Session Host Configuration-> RDP-tcp-> Right click-> Properties-> Client Settings. Audio option should be unchecked. Similarly check for ICA-Tcp connection.
- Allow Citrix client audio redirection policy in studio console.
- Run gpupdate /force on the VDA server.
- Verify that Receiver setting for audio is enabled in connection center.
- We should be able to get audio working in ICA session.
Steps to be followed on Win 8 and 2012 R2 and above.Due to the changes in Server 2012 R2, there is no option to modify RDP listener in RDMS (Remote Desktop Management Server) GUI, hence to enable this Audio Redirection in 2012 R2 server, follow the below steps:
- Choose Start, choose Run, enter regedit, choose the OK button, and then set the value of the following registry key to 0.
- Go to HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\, Edit or create
Value: fDisableAudioCapture
Type: REG_DWORD
Data : 0
Problem Cause
Client audio redirection was prohibited.
Issue/Introduction
Error: "No Audio Available, Could NoT Open An Audio Device For Playback" In ICA Session. : "No audio available. Could not open an audio device for playback. Automatic audio device detection failed. Audio playback will not be available during this session.
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