Update MCS Catalog Completed But Some VMs Haven't Been Updated

Update MCS Catalog Completed But Some VMs Haven't Been Updated

book

Article ID: CTX220711

calendar_today

Updated On:

Description

Update machine catalog task is successfully. But some VDAs in the catalog haven't been updated.

Resolution

Find the StorageID of all affected VDAs in the catalog,
  • Run Below PowerShell Command to get ProvisioningSchemeUid
  • asnp citrix*
  • Get-ProvScheme -ProvisioningSchemeName Catalogname
  • Record the ProvisioningSchemeUid for this catalog
  • Connect to Database Server and open table DesktopUpdateManagerSchema.ProvisionedVirtualMachine
  • Record StorageId for above ProvisioningSchemeUid
  • Open table DesktopUpdateManagerSchema.ProvisioningSchemeVMImageLocation
  • Check if all StorageId record in this table for above ProvisioningSchemeUid
  • if not, please Remove these VMs from catalog and Create them again

Problem Cause

BaseDisk info is missing from database table DesktopUpdateManagerSchema.ProvisioningSchemeVMImageLocation

Issue/Introduction

Update MCS catalog task is completed, But some VMs haven't been updated