License server 11.14 - Cannot display the webpage

License server 11.14 - Cannot display the webpage

book

Article ID: CTX220598

calendar_today

Updated On:

Description

Unable to open Citrix License Administration console in IE brower, you will get below error:

"The Page cannot be displayed"

Resolution

Recommended: Enable TLS 1.1 or 1.2 in security under Advanced tab in IE options.

However, you could also enable TLS 1.0 on license server:
  1. Create a backup of the server.xml file by copying it to temporary location. You can then restore the backed up file if necessary. For Linux VPX, the server.xml file is at /opt/citrix/licensing/LS/conf/server.xml, for Windows License Server, it's at %InstallationPath%\Citrix\Licensing\LS\conf\server.xml.
  2. Open server.xml for editing and remove -TLSv1 in the sslProtocol attribute under the webServer node. Before editing, the webserver node should look like this:
    <webServer documentRoot="web" logRoot="logs" maxRequestSize="4" maxThreads="10" pageSize="20" port="0" redirectHTTP="false" securePort="8082" sslCiphers="ALL:!MEDIUM:!LOW:!aNULL:!eNULL:!RC4:!EXP:!CAMELLIA:!DH:!3DES" sslProtocol="+All -SSLv3 -SSLv2 -TLSv1">
    
  3. Restart the Citrix Licensing service: #/etc/init.d/citrixlicensing restart. For Windows License Server, you need to restart the Citrix Licensing service in Services Panel.

  4. After that, you should able to open the Citrix License Administration console in IE brower with TLSv1.

Problem Cause

License server 11.14 doesn't support access the web administration console with TLS 1.0 by default.