WEM Agent Error: "Connection state changed - WEM agent has detected that the network connection has been lost. Click here to refresh your environment settings"

WEM Agent Error: "Connection state changed - WEM agent has detected that the network connection has been lost. Click here to refresh your environment settings"

book

Article ID: CTX220568

calendar_today

Updated On:

Description

Random WEM Agent machines intermittently display the following pop up error message:
"WEM Agent Error:  "Connection state changed - WEM agent has detected that the network connection has been lost. Click here to refresh your environment settings"

Resolution

Increasing the amount of delegated vCPU and RAM resources on WEM Broker(s) to 4 vCPUs and 16 GBs of RAM.

 

Problem Cause

Low resources for CPU and RAM on the WEM broker. We saw on the agent service log:

Exception -> ConfigurationDataSourcesHelper.CheckAgentBrokerServiceClient() : System.ServiceModel.ServerTooBusyException : The request to create a reliable session has been refused by the RM Destination. Server 'net.tcp://localhost:8286/AgentBrokerSvc/service' is too busy to process this request. Try again later. The channel could not be opened.

Exception -> ConfigurationDataSourcesHelper.CheckBrokerSvcConnection() : Broker Svc Check -> Failed