StoreFront upgrade fails ""The process cannot access the file 'C:\inetpub\wwwroot\Citrix\<store name>\web.config' because it is being used by another process." 

StoreFront upgrade fails ""The process cannot access the file 'C:\inetpub\wwwroot\Citrix\<store name>\web.config' because it is being used by another process." 

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Article ID: CTX220464

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Description

In the MSI logs under C:\windows\temp\storefront we see the following exception:

"The process cannot access the file 'C:\inetpub\wwwroot\Citrix\<store name>\web.config' because it is being used by another process." 

Resolution

Prior to running the upgrade use IIS manager to: 

1. Stop the CitrixDeliveryServicesResources application pool. 

2. Edit the advanced settings of the CitrixDeliveryServicesResources application pool so that its start mode is OnDemand. 

3. Deleting the Proxy cache (if present) C:\inetpub\wwwroot\Citrix\<all folders>\App_Data\CtxsWebProxyIconCache\ 

4. Rename the StoreFront install folder to the latest version under C:\ProgramData\Citrix\Storefront Install. Or remove the StoreFront install folder. 

5. Run the installer as an administrator.

6.When the upgrade is complete return the application pool to always running.


Problem Cause

This error might be occurring because the application pool has started running which locks the file preventing the feature package from updating the web.config file.