XenDesktop 7.12 MCS Newly Created XenServer VMs Are Reporting "XenTools Not Installed"

XenDesktop 7.12 MCS Newly Created XenServer VMs Are Reporting "XenTools Not Installed"

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Article ID: CTX220053

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Updated On:

Description

After installing XenDesktop 7.12, MCS created VMs are reporting  XenTools and XenDrivers not installed. The network adapter on the VMs is showing as Realtek adapter instead of the Xen adapter.

Resolution

A private hotfix is available for this issue. Contact Citrix Support to obtain the hotfix. The private will only affect newly created catalogs

  1. Download the private LC6769.
  2. Stop the Citrix Host Service.
  3. Stop the Citrix Machine Creation Service.
  4. Stop the Broker Service.
  5. Access this directory:C:\Program Files\Common Files\Citrix\HCLPlugins\Hypervisor\v2.20.0.0\XenServer.
  6. Back up the following files: HypervisorCommon.dll; XenServerPlugin.dll.
  7. Extract the Files from the Zip folder and place them on the same directory.
  8. Start the Services back ON.
This issue has been fixed in the 7.13 release of XenDesktop.

Problem Cause

Deployed MCS VMs are not cloned correctly on XS - LC6769

Issue/Introduction

After installing XenDesktop 7.12, MCS created VMs are reporting  XenTools and XenDrivers not installed. The network adapter on the VMs is showing as Realtek adapter instead of the Xen adapter.

Additional Information

http://discussions.citrix.com/topic/383281-xendesktop-712-mcs-xenserver-pv-network-device-issues/