Error: "The personal vDisk inventory failed to update" after Upgrading PVD in XA/XD from 7.11 to 7.12

Error: "The personal vDisk inventory failed to update" after Upgrading PVD in XA/XD from 7.11 to 7.12

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Article ID: CTX219612

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Updated On:

Description

This article describes an issue that may arise when performing an upgrade from XenApp/XenDesktop 7.11 to version 7.12.

Consider a scenario where you have installed XA/XD 7.11 VDA on a virtual machine and have created a Personal vDisk. If you run the XA/XD 7.12 installer and install the VDA in the machine, installation appears successful. However, if you then attempt to run the task to “Update personal vDisk”, the inventory operation will fail with the following error:
The personal vDisk inventory failed to update. 
An internal error occured. Review the personal vDisk logs for further details. Error code 0x2.


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Note: This issue occurs only in an upgrade scenario and not in a fresh install XenApp/XenDesktop 7.12 VDA product.

Resolution

Any of the following methods can be adopted to resolve this issue:

  • Repair the personal vDisk installation
  • Remove the personal vDisk installation, and reinstall it

Both options require you to first select the appropriate copy of the personal vDisks installer from your XenApp/XenDesktop media.

  1. Obtain the latest personal vDisk MSI installer from the XenApp/XenDesktop ISO from one of the following directories (depending on whether VM to be upgraded is 32 or 64-bits).
    • 32-bits: XA and XD\x86\Virtual Desktop Components\personalvDisk_x86.msi
    • 64-bits: XA and XD\x64\Virtual Desktop Components\personalvDisk_x64.msiUser-added image

Repair the Personal vDisk Installation

  1. Double click the personal vDisk MSI installer package found in the earlier section. The Welcome page appears; click Next:User-added image
  2. The personal vDisk setup screen appears. Select Repair; click NextUser-added image
  3. The Ready to repair Citrix personal vDisk page appears. Click Repair:User-added image
  4. Click Finish to complete the repair process:
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  5. Click Finish to complete the repair process:
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Remove the personal vDisk installation, and reinstall it

  1. Double click the personal vDisk MSI installer package found in the earlier section.   The Welcome page appears; click Next:User-added image
  2. The personal vDisk setup screen appears. Select Remove; click Next.
  3. The Ready to remove Citrix personal vDisk page appears. Click Remove:User-added image
  4. Click Finish to complete the repair process:
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  5. Click Yes to restart the system and to apply your configuration changes:User-added image
  6. Login to the VDA, then double click the MSI installer package; the Citrix personal vDisk Setup appears.  Select the Accept the terms.. checkbox, then click Install:
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  7. Click Finish to complete the installation:
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  8. Click Yes to restart the system and to apply the configuration changes made to the personal vDisk:User-added image

Problem Cause

When performing such an upgrade, important Windows Registry entries and software components will not be installed, leading to an incomplete upgrade. As a result, normal PVD tasks, such as “Update personal vDisk” may generate errors and not work properly.

Issue/Introduction

This article describes an issue that may arise when performing an upgrade from XenApp/XenDesktop 7.11 (or earlier) to version 7.12.