Secure Mail strips attachments from digitally signed emails

Secure Mail strips attachments from digitally signed emails

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Article ID: CTX219229

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Updated On:

Description

Attachments are not being shown on digitally signed emails in Secure Mail.

Information

  • Secure Mail supports Secure/Multipurpose Internet Mail Extensions (S/MIME), enabling users to sign and encrypt messages for greater security. Signing assures the recipient that the message was sent by the identified sender and not an imposter.
  • Encryption allows only the recipients with a compatible certificate to open the message.

Please ensure that the prerequisites are met and the setup is configured correctly.

  1. For prerequisites, refer to https://docs.citrix.com/en-us/citrix-secure-mail/s-mime.html#prerequisites-1
  2. For information on how to configure correctly, refer to https://docs.citrix.com/en-us/citrix-secure-mail/s-mime.html#configuring-the-integration 

Resolution

For iOS devices:

  1. Enabling “S/MIME” in Secure Mail will show attachments of digitally signed emails received after the said option is enabled.
  2. To access attachments of older digitally signed emails, the “Enable S/MIME during first Secure Mail startup” policy needs to be ON in the XenMobile Server console.  Thereafter, deleting the email account and re-adding it will allow attachments to be seen on older emails.
  3. For first-time users to have S/MIME enabled by default, set the “Enable S/MIME during first Secure Mail startup” policy to ON in the XenMobile server console.

If you still continue to run into issues, please contact support.


Problem Cause

S/MIME is being turned off by default in Secure Mail due to a XenMobile Server console policy.

Additional Information

Refer to https://docs.citrix.com/en-us/citrix-secure-mail/s-mime.html for more information