Some UPM or WEM Agent parameters may not be applied by the agent after switching from GPO settings to Workspace Environment Management settings.
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Article ID: CTX219086
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Updated On:
Description
Symptom 1:
WEM Policy/Settings are not applying, and the old Citrix Profile Management items are applying instead
Symptom 2:
WEM Policies are not applying to the WEM Agents
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
Solution 1: Bypass the WEM Cache via WEM Console
- Access the WEM Console
- Navigate to Administration > Agents
- Navigate to Statistics Sub-Menu
- Select Reset Actions...
- On the Reset Actions Pop-up Menu, select Registry Values, Environment Variables, Environment Settings
- Select "Reset"
- Close the Pop-up Menu
- Right Click the Agent(s) and select "Refresh Agent Host Settings"
Solution 2: Removing the Citrix Profile Settings from the Microsoft Registry of the VDA Machine/Agent Machine
DISCLAIMER:
Take caution when editing any values in the registry as it can cause damage to the system. Perform a backup of the machine before making any registry changes.
- Access the Microsoft Registry of the Agent Machine/VDA Machine
- Navigate to the following Registry Keys:
- HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Norskale\Agent Host\UsvMachineConfigurationSettings
- HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Norskale\Agent Host\UPMConfigurationSettings
- Remove the Values within the Registry Keys listed above
- Restart the Machine
- This will force the VUEM UI Agent to re-apply the per-machine settings (Microsoft USV or Citrix UPM settings, respectively)
Problem Cause
In order to optimise Windows performance, Workspace Environment Management has two caches stored in the registry:
- a per-machine cache which stores non-user parameters (Microsoft USV, Citrix UPM) and
- one per-user cache which stores user parameters (assigned actions, start menu settings, etc.).
These caches are used to indicate which settings have already been applied and do not need to be re-applied.
In some cases (e.g. migrating a profile from a WEM server to a GPO server and back), the cached settings may cause the Citrix WEM Agent not to apply some settings properly.
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