Error "License cannot be retrieved. Either the NetScaler..." When Adding NetScaler Instance to NetScaler MAS Inventory

Error "License cannot be retrieved. Either the NetScaler..." When Adding NetScaler Instance to NetScaler MAS Inventory

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Article ID: CTX218359

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Updated On:

Description

When trying to add NetScaler instance to inventory it fails with the following error message:
"Trying to connect to "IP_of_the_NetScaler"
Error: License cannot be retrieved. Either the NetScaler is unresponsive or the login credentials are incorrect."

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Resolution

Complete the following steps to resolve this issue:

  1. Login to the NetScaler GUI and click on Configuration > Network > IPs.

  2. Select the NetScaler IP (NSIP), click Edit and ensure that Enable Management Access control to support the below listed applications is checked.

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  3. Login to NetScaler MAS GUI and go to Modify system settings and change the setting Communication with instance(s) from HTTPS to HTTP.

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Problem Cause

This is known issue in this build and has been fixed in fixed in 11.1 MR2 build. Starting from this build you can add NetScaler MAS with HTTPS enabled.

Issue/Introduction

When trying to add NetScaler instance to inventory it fails with the following error message: Error: License cannot be retrieved. Either the NetScaler is unresponsive or the login credentials are incorrect.