Load Index - Server load 10000

Load Index - Server load 10000

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Article ID: CTX218335

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Updated On:

Description

  • Server VDA load index shows 10000 in the Citrix Studio.
  • The issue starts happening after configuring the Load Index Policy for Memory Usage.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

We have to rebuild Performance Counters with LODCTR from an elevated command prompt.

  • Launch Command Prompt as Administrator (right click Runs As Administrator).
  • Drop into the C:\WINDOWS\System32 directory by typing CD\ then CD Windows\System32
  • To rebuild your resource counters type the following command:
            lodctr /r
  • This will rebuild your counter values and may take a few moments so please be patient.
  • Once the rebuilding operation is done, close the command prompt.
  • Restart the Citrix Desktop Service on the VDA where you have rebuild the counters.

If the Load Index value still shows 10000 on the Citrix Studio for the VDA where the changes have been made, follow the below steps to identify if any of the Operating System counters is disabled.
  • Launch Command Prompt as Administrator (right click Runs As Administrator).
  • Drop into the C:\WINDOWS\System32 directory by typing CD\ then CD Windows\System32
  • To query the state of the performance counters, run the below command.
           lodctr /q 

This will give you something like the following:

Performance Counter ID Queries [PERFLIB]:

    Base Index: 0x00000737 (1847)

    Last Counter Text ID: 0x000031D2 (12754)

    Last Help Text ID: 0x000031D3 (12755)

 

[.NET CLR Data] Performance Counters (Disabled)

    DLL Name: %systemroot%\system32\netfxperf.dll

    Open Procedure: OpenPerformanceData

    Collect Procedure: CollectPerformanceData

    Close Procedure: ClosePerformanceData

 

[.NET CLR Networking] Performance Counters (Enabled)

    DLL Name: %systemroot%\system32\netfxperf.dll

    Open Procedure: OpenPerformanceData

    Collect Procedure: CollectPerformanceData

    Close Procedure: ClosePerformanceData

and etc

If you find any of the performance counters disabled on the VDA server, follow the below steps to enable them.

In the query if you have provider name that is Disabled, Use this Cmdlet to enable it.

lodctr /e:<provider name>

for example (think in above query Performance Counters is disable ) :

lodctr /e:Performance Counters

If you perform this step and it doesn't work, please see the event log and search for if there is Event ID = 3006 in it? if yes, 

Please go to registry and change Disable Performance Counters from "1" to "0".

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib

 


Problem Cause

  • The base OS performance counters were disabled on the VDA.

Note: 

To confirm the problem open the perfmon on the server VDA.

1) Go to Start -> Run
2) Type Perfmon and Click ok.
3) The following error will pop up if there is an issue with a specific counter.


"Unable to add these counters:

\Memory\Available MBytes
\Memory\% Committed Bytes In Use
\Memory\Cache Faults/sec
\Memory\Cache Faults/sec


 

Issue/Introduction

Load Index value for Virtual Delivery Agent servers showing 10000 in Citrix Studio