After HRP07 error "You need permission to perform this action" appears when creating a file on a mapped client drive.

After HRP07 error "You need permission to perform this action" appears when creating a file on a mapped client drive.

book

Article ID: CTX217771

calendar_today

Updated On:

Description

Since applying HotFix Rollup Pack 7 to a  XA 6.5 farm Client Network Drive Mapping no longer works. 

The client drive is mapped to the session . However when trying to create a folder/file the error "You need permission to perform this action" appears.



Problem was not seen on Hotfix Rollup pack 5.

Resolution

Error message would imply that read-only drives are enabled on the server  as per http://support.citrix.com/article/CTX124356.

However this was  not the case as below key was  set to 0.

HKEY_LOCAL_MACHINE\SYSTEM\Current Control Set\services\picadm\Parameters\ReadOnlyMappedDrive

Value: 0

A CDF Trace shows this error.

 

682536 \src\ica\HostCore\WorkStation\picadm 10844  32320  14/09/2016 08:09:54.965   pdm.cpp    PdmFsdQueryPath    1198   TC_FSDTRACE PdmFsdQueryPath Entry Path:\Client\C$\int\New folder

682664 \src\ica\HostCore\WorkStation\picadm 10844  32320  14/09/2016 08:09:54.965   pdm.cpp PdmFsdCreate    3207   TC_FSDTRACE PdmFsdCreate ReadOnlyMappedDrive. File / directory creation not allowed. FN:New folder.


The solution is to disable the setting for  for read-only client drive access  under ICA\File Redirection n the Citrix user Policies.


User-added image

Problem Cause

Below  fix is included in HRP07.

User based policy for read-only drives under ICA\File Redirection\Read-only client drive access are not honored. As a result, users subject to that policy are able to write to read-only drives.
[From XA650W2K8R2X64R07][#LC3080]

Prior to HRP07 the the policy setting for Read-only client drive acces was inoperative . Althought the setting was enabled in the policy setting  it had no effect. This explains why it appeared issue was caused by HRP07.