Error:"An SSL connection to the server couldn't be established" when using Workspace App for Linux

Error:"An SSL connection to the server couldn't be established" when using Workspace App for Linux

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Article ID: CTX217590

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Updated On:

Description

When trying to authenticate to a StoreFront server using the StoreFront URL you get the error:

An SSL connection to the server couldn't be established because the server's certificate was not trusted.
An SSL connection to the server couldn't be established because the server's certificate was not trusted

Resolution

1. Obtain the root certificate in PEM format.

Tip: If you cannot find a certificate in this format, use the openssl utility to convert a certificate in CRT format to a .pem file.

2. As the user who installed the package (usually root):

  •  Copy the file to $ICAROOT/keystore/cacerts.
  •  Run the following command: $ICAROOT/util/ctx_rehash

Problem Cause

Receiver needs root certificate to verify the signature of Certificate Authority on the server certificate

Additional Information

For more details, refer: https://docs.citrix.com/en-us/citrix-workspace-app-for-linux/system-requirements#connections-and-certificates