Users Are Unable To Launch Applications - Error:"The Task You Are Trying To Do Can't Be Completed Because Remote Desktop Services Is Currently Busy." 

Users Are Unable To Launch Applications - Error:"The Task You Are Trying To Do Can't Be Completed Because Remote Desktop Services Is Currently Busy." 

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Article ID: CTX217482

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Updated On:

Description

Users are not able to launch applications and receive the following error message: "The task you are trying to do can't be completed because Remote Desktop Services is currently busy." 

Resolution

This is a Microsoft Issue and installing the following updates should resolve it: 
  • Available Updates for Remote Desktop Services on Windows Server 2012 R2: KB2933664
  • For Windows Server 2008 R2 Remote Desktop Services updates: KB2601888
  • For Windows Server 2012 Remote Desktop Services updates: KB2821526
  • Available Updates for Remote Desktop Services on Windows Server 2008 R2 SP1: KB2752618 
  • RDS client computer cannot connect to the RDS server by using a remote desktop connection in Windows: KB2752618
  • KB2775511 - This is a roll-up update for the printing core components in Windows 7 and in Windows Server 2008 R2. 
  • KB3014783 - "RDS busy" or "The Group Policy Client failed logon" error when you log on to an application in Windows Server 2008 R2

Problem Cause

The remote computer requires Network Level Authentication, which your computer does not support.

Additional Information

You can now use the Application probing feature to proactively monitor the health of applications enabling you to fix issues before the user actually experiences them. For more information refer to Citrix Documentation - Application probing.